News:

The forum has been updated to SMF (2.1.3)!
Please be patient as we work to polish up the place and update features as we can.

Main Menu

My somewhat odd hack

Started by Aile~♥, 26, January, 2010, 06:33:17 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Atrius (He/Him)

Alright, let's try to figure out this class system error so I can see if it's something I need to fix in the editor, or what.

To help me out for starters I would like a copy of your save file where you're experiencing the error, Jamie, and the MD5 checksum of both you, and Role's original unmodified files of The Lost Age.  (You can use this program to calculate it, use the Unicode version)
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

Alright, first thing: I also cannot get ABILITIES to change in-game, despite the changes showing up in the editor.

Also, MD5 checksum of WHAT? The save file? The game itself?
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Atrius (He/Him)

I have a feeling there's a possibility that may be related to the other problems, I'll look into it either way.

The MD5 checksum of your original unhacked copy of The Lost Age itself.
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

Is it OK to post it in the topic, or do I need to PM you?
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Atrius (He/Him)

An MD5 checksum is just a string of characters to check if files are identical or not, there's no problem posting it here.
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

489C76FC7DE7B5B930345B96C0BB95EE <there it is.

And as for the save file, can I post it here? It would be difficult to send it in PM (because there's no "attach" option for PMs), unless I uploaded it somewhere, which would be potentially even more risky.
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Atrius (He/Him)

The only thing you really can't post are commercial ROM files themselves, or specific information on how to obtain them.  Yes save files are fine.
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

*see attached* V Note: Yes it is just a save file.
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Atrius (He/Him)

First thing I notice is that your copy of the game is different from mine.  After getting my hands on yours, and inspecting the differences I've determined that a custom script was inserted into it that's executed before the game boots.  I'm not certain what the purpose of the script is, but none of the data in the game has been altered so I doubt it's contributing to the problems.

After putting all of Sheba's Djinni to stand by, and setting them all again the errors seem to have fixed themselves, are you sure you reset her class properly after making edits?
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

I have reset her class properly, I've done it several times, the errors still haven't fixed themselves.
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Atrius (He/Him)

Would you mind stepping me through what exactly you did so I can see if I can duplicate the results?
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

Well, first I put the abilities in the order learned, then I decided to put them in the right order, but in doing so I had duplicates of some abilities at times.
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Atrius (He/Him)

... And so far as resetting Sheba's class, but still getting the errors?
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

What do you mean by "resetting"? If what you mean is Djinn, I standby'd and then reset every djinni on Sheba, and tried the same on Jenna. It didn't work, when I set the Djinn back, she still had duplicate Psynergy, and the duplicates were the same as before.
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Atrius (He/Him)

Apparently you gave me the wrong save file then, Jenna doesn't have any duplicate Psynergy.
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

Jenna doesn't have duplicates, but they are all in the wrong order.
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Atrius (He/Him)

*sets all of her djinni to standby at the same time, then sets them all again*

Fixed it.  I assume you are using the last version of the patch you uploaded applied to the same copy of TLA you gave me the MD5 hash for?
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

#37
Yes I am. So using Standby All/Set All works? Ok I'll try that.

Edit: Strange, I tried that, didn't work for me.

I've also started a new game on that save which also didn't work, still has the glitchy duplicates.
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Atrius (He/Him)

Heh, hah hah.

I think I see whats going on.  Do this for me, in VBA go to Options > Emulator, make sure that "Automatic IPS patching is not checked, then reload the ROM file (don't just reset the emulator, completely reopen the ROM file through the file menu), and try resetting their classes again.
[sprite=220,4,0]I'm shaking my head in general disapproval of everything[/sprite]

Aile~♥

That did it! Thanks!

Now I just feel stupid. XD

Yippy!
[sprite=16, 6, 0]:P[/sprite]

Lloyd: Easy as pie.
Genis: Sweet!
Presea: ...Sweetie pie...
Zelos: Let's not start on this again...

[spoiler=epic mindscrew][/spoiler]

Affiliates
Temple of Kraden